ThinkSNS 发布于 2017-11-01 14:34
  • web
  • 看了Taylor Otwell发表的Package AutoDiscovery In Laravel 5.5第一反应是

    图片1.png

    为啥。。。

    也怪我,在开发之前忘记看5.5的开发代码动态,之前的文章中也提到过,在ThinkSNS+开发场景中,我们不可能让用户去 config/app.php 修改配置,所以为了解决加载包的问题,我们开发了Laravel服务提供者的增强版可以看plus/doc/pakcage

    是的,增强版的服务提供者,增加功能如下:

    l 可以友好的加载其他「服务提供者」(这在开发包的时候需要依赖其他laravel拓展包很有用)

    l 服务提供者转到composer.json配置(无需修改配置了)

    l 针对包更友好的publish(Laravel的vendor:publish要求输入服务提供者类,我们的只要求输入包名称)

    l 处理器,简化版的命令行,可以用一个函数写一个简单的处理方法。

    看到第二个就知道了,和laravel 5.5的自动发现类似,我们是在 bootstrap/cache/providers.php 中记录服务提供者信息,而Laravel 5.5是在vendor目录中查找后写入到 bootstrap/cache/package.php 。

    是的,我们的实现思路差不多,但我们支持更多功能。从这里读取服务提供者列表,然后在 Illuminate\Foundation\Application::registerConfiguredProviders 函数中合并服务提供者,然后加载,从服务提供者中还可以继续加载服务提供者。

    说下我的心情,大概是这样:图片2.png,又喜又悲~

    开心,高兴,Laravel更易用了,另一个心情;

    惆怅,因为我在ThinkSNS+中开发了这一特性后,公司包几乎都是以这种方式实现的。

    你会说,把这些包配置字段设置下不就好了嘛?可是,在这种方式没定型之前,已经修改过一次,难道一个多月后又要修改一次?惨不忍睹呀!!!我怕我会被揍,想想就有点痛。

    图片3.png

    今天在群里说这个话题,某开发者:“哈哈,我终于开发了画中画功能”,然后谷歌:“Android 8 原生支持”。其实道理一样的,并不是因为官方原生支持了不好,而是在纠结,用官方的?还是继续维护自己的?自己的不一定有官方好,官方支持更稳定。

    总结,我们觉得废弃掉现在的安装器(bootstrap/cache/providers.php 是由Composer安装器插件写入的),然后增加一份代码,从vendor目录匹配出来,写入到 bootstrap/cache/package.php 中去,只为5.5做准备。来吧!!!

    开源代码仓库

    GitHub:https://github.com/zhiyicx/thinksnsplus(点击star,每日关注开发动态。)

    ThinkSNS体验地址:http://www.thinksns.com/experience.html

    1 个回答
    • 技术QQ交流群:294088839

      2017-11-22 18:08 回答
    撰写答案
    今天,你开发时遇到什么问题呢?
    立即提问
    活跃用户
    • 1
      问道摩托
    • 2
      袁广龙976丶
    • 3
      逍遥子
    • 4
      亮仔
    • 5
      芙蓉花
    • 6
      mobiledu2502871817
    • 7
      作小die_syj
    • 8
      王丽珠景平怡伦_621
    • 9
      adfa3sd5f6a
    • 10
      欣欣大妮
    PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
    Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有