金子祺_475 发布于 2017-04-30 06:12

服务器当前安装的PHP5.4

现在想部署lumen框架上去。

需要PHP5.6或以上版本,而且需要安装那几个扩展。

我想要不直接安装个PHP7上去好了。搜了个YUM安装PHP7的命令

rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm
yum install -y php70w php70w-opcache

先不说是否可以正常安装,现在有个问题就是如何在安装命令里把OpenSSL PHP Extension、PDO PHP Extension、Mbstring PHP Extension这三个扩展的安装也加到命令里? 或者说,如果先安装好PHP7了,如何再安装着几个扩展?

搜索的资料杂七杂八的。。希望有经验的朋友给简单说说哈,谢谢。

2 个回答
  • Docker解决一切环境问题。如果实在不想自己写Dockerfile,也有现成的Laradock。

    2017-04-30 06:54 回答
  • yum源分两种

    • 一个是官方维护的源

    • 另一种是社区维护的epel源。

    rpm包是作者编译好的安装包。自己不能在其基础上再定制。
    对于的epel包,相对与官方包看作者人品了
    不过php安装完成以后,可以再添加扩展。添加扩展的方式,是要编译安装库文件。

    2017-04-30 09:59 回答
撰写答案
今天,你开发时遇到什么问题呢?
立即提问
活跃用户
  • 1
    问道摩托
  • 2
    广告公司英子
  • 3
    袁广龙976丶
  • 4
    逍遥子
  • 5
    亮仔
  • 6
    芙蓉花
  • 7
    作小die_syj
  • 8
    王丽珠景平怡伦_621
  • 9
    adfa3sd5f6a
  • 10
    欣欣大妮
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有