诚实宝贝2002 发布于 2017-05-13 21:13

初步接触Phalcon,跟着官方文档写代码
文件结构与官方一致

tutorial/
  app/
    controllers/
    models/
    views/
  public/
    css/
    img/
    js/

分别在根目录和public目录添加了.htaccess文件
代码分别如下:

./htaccess


    RewriteEngine on
    RewriteRule  ^$ public/    [L]
    RewriteRule  (.*) public/$1 [L]

./public/.htaccess

AddDefaultCharset UTF-8

    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php?_url=/$1 [QSA,L]

按照官方文档,在浏览器地址栏输入localhost/tutorial/是可以访问到public/index.php文件的
但是我输入localhost/tutorial 会提示

Forbidden

You don't have permission to access /tutorial/ on this server.

直接输入localhost/tutorial/public/index.php 可以正常访问,也可以显示该有的内容

我的apache版本是2.4.10,配置文件已经修改成了

 DocumentRoot "/Users/anneason/www/"                                


Options FollowSymLinks Multiviews
MultiviewsMatch Any
AllowOverride All
Order deny,allow
Allow from all


修改访问权限之后还是无法访问,并提示上述“没有权限”的信息

遇到这种问题该如何解决,已困扰多时,求帮助,谢谢 :)

2 个回答
  • OSX

    自己检测phpinfo(),是否开启mod_rewrite

    结果发现没有开启

    然后开启重启就可以了

    谢谢O(∩_∩)O

    2017-05-14 20:12 回答
  • 我猜你apache是2.0的吧;
    如果是Apache 2.0 Handler;比如Mac自带的就是这版本;
    那么就到Apache下面找到httpd.conf,然后把以下这段加进去:

    # use .htaccess files for overriding,
    AccessFileName .htaccess
    # and never show them
    <Files ~ "^\.ht">
        Order allow,deny
        Deny from all
    </Files>
    2017-05-14 16:33 回答
撰写答案
今天,你开发时遇到什么问题呢?
立即提问
活跃用户
  • 1
    问道摩托
  • 2
    袁广龙976丶
  • 3
    逍遥子
  • 4
    亮仔
  • 5
    芙蓉花
  • 6
    作小die_syj
  • 7
    王丽珠景平怡伦_621
  • 8
    adfa3sd5f6a
  • 9
    欣欣大妮
  • 10
    狂风DKC想毕业321
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有