判官-包公_529 发布于 2017-05-15 11:52

原因:
最近php爆出了一个multipart/form-data的漏洞,我用的是Zend Server CE 5.6, php版本是5.3.14, 官方没有针对此版本的修复方案。
问题:
想着通过更改zend server中使用的php源码,然后重新编译来修复这个问题,是否可行?如果可行,是否可以给个步骤,另外系统中用到了zend server的java_bridge 等其他的模块,这些应该如何处理?
(不能升级Zend server,系统为Ubuntu 10.04.4)

1 个回答
  • 我自己来回答吧。
    不用考虑问题中提到的java_bridge之类的模块,只要安装Zend Server中使用的php源码之后,就可以按照正常从源码安装php的步骤去编译,安装了。
    可能遇到的问题:
    1.不知道configure选项
    可以使用php-config --configure-options来查看之前的configure选项,可能需要对应地改一些配置的值。
    2.可能会缺少编译环境所需要的软件
    我在重新编译的时候安装的有libxml2-dev, openssl-dev, zlib-dev.

    2017-05-16 09:33 回答
撰写答案
今天,你开发时遇到什么问题呢?
立即提问
活跃用户
  • 1
    问道摩托
  • 2
    袁广龙976丶
  • 3
    逍遥子
  • 4
    亮仔
  • 5
    芙蓉花
  • 6
    作小die_syj
  • 7
    王丽珠景平怡伦_621
  • 8
    adfa3sd5f6a
  • 9
    欣欣大妮
  • 10
    sfasfs
PHP1.CN | 中国最专业的PHP中文社区 | json解析格式化 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | 在线工具
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有