hfy2409553 发布于 2017-05-09 10:46

前提 不能更换系统 和 环境.............所以不用考虑Linux了.....

环境 wampserver 要求更换PHP版本....目前我已经在wampserve中加入了 php5.5.17 但是好像没有办法切换.....求教有遇到类似问题的 伙伴吗??
图片是在本地装的wampserver 进行测试.....

2 个回答
  • wampserver我折腾过 确实可以像你需求的那样 不过得更改配置文件 具体哪几个不记得了 可以在目录下翻一下相关的php文件 他的配置脚本是php写的。

    其他备选方案
    1. 找个另外支持多版本切换的软件 我记得 phpstudy 好像可以。
    2. 用虚拟机的形式, 推荐用 vagrant 绝对是利器 如果最终部署就是在linux上 还是建议用linux环境 不管是真实的还是虚拟的 免得又冒出其他未知 bug。

    2017-05-10 00:56 回答
  • 自己给答案吧 已经搞定...

    把PHP版本放入之后 需要复制一份 wampserver.conf 文件进去 然后修改其中的代码 增加 Apache 2.4 即可 不需要修改 网上传言的 wampmanger.ini 这个文件在每次启动 wamp的时候会被重新生成 具体可以看下 wamp/scripts/refersh.php 文件......

    bingo.........就这样搞定了.........................

    2017-05-09 15:32 回答
撰写答案
今天,你开发时遇到什么问题呢?
立即提问
活跃用户
  • 1
    问道摩托
  • 2
    袁广龙976丶
  • 3
    逍遥子
  • 4
    亮仔
  • 5
    芙蓉花
  • 6
    作小die_syj
  • 7
    mobiledu2502875483
  • 8
    王丽珠景平怡伦_621
  • 9
    adfa3sd5f6a
  • 10
    欣欣大妮
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有