王妃2502872393 发布于 2017-05-11 23:09

如下:

brew install php56-xhprof
==> Installing php56-xhprof from homebrew/homebrew-php
==> Downloading https://github.com/facebook/xhprof/archive/254eb24dcfa763c76c57b472093ebc4b81af2b7d.tar.gz
######################################################################## 100.0%
==> Patching
Error: Unable to guess PHP branch for Formulary::Formulae::Php56Xhprof
1 个回答
  • 应该是PHP版本有问题,homebrew-php的源码,你尝试安装一下5.3+的版本。

    def php_branch
        class_name = self.class.name.split("::").last
        matches = /^Php5([3-9]+)/.match(class_name)
        if matches
          "5." + matches[1]
        else
          raise "Unable to guess PHP branch for #{class_name}"
        end
      end
    
    2017-05-12 17:24 回答
撰写答案
今天,你开发时遇到什么问题呢?
立即提问
活跃用户
  • 1
    问道摩托
  • 2
    袁广龙976丶
  • 3
    逍遥子
  • 4
    亮仔
  • 5
    芙蓉花
  • 6
    作小die_syj
  • 7
    王丽珠景平怡伦_621
  • 8
    adfa3sd5f6a
  • 9
    欣欣大妮
  • 10
    狂风DKC想毕业321
PHP1.CN | 中国最专业的PHP中文社区 | PHP资讯 | PHP教程 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有